Место для вас

Обновление composer-asset-plugin

Бывает такое, что при попытке установить некоторые зависимости через composer у вас в консольке появляется следующая ошибка:

Fatal error: Call to undefined method Fxp\Composer\AssetPlugin\Package\Version\VersionParser::parseLinks() in бла...бла...бла...

В двух словах - это ошибка говорит вам, что: "Эй, чувак, ты юзаешь старую версию composer-asset-plugin. И чтоб установить зависимости, то тебе нужно сперва обновить composer-asset-plugin."

Решение простое!!!

Сперва нужно удалить старую версию composer asset plugin:


#для Linux:
rm -rf ~/.composer/vendor/fxp

#для Windows:
rm -r %APPDATA%\Composer\vendor\fxp

И заново переустановить его:


composer global require "fxp/composer-asset-plugin:~1.1.1"

Вуаля. Теперь смело обновляйте или устанавливайте новое. Ошибка не должна уже вас беспокоить.


Место для вас

Коментарии

добавить коментарий

  1. Andrey - 24 ноября, 2016 в 10:01:50

    Единственное решение которое мне реально помогло ! Спасибо !

Добавить коментарий

кликните на картинку,
чтоб обновить код

Что за сайт

Этот сайт представляет унифицированную базу, где инфа собрана в единое целое, а не разбросанна по многочисленным сайтам, записям на листах бумаги или головам людей; а так же доступна круглосуточно не зависимо от кого-либо или чего-либо.

Будь в курсе

Интересненько

Вверх